PT-2012-4432

CVE-2012-3008

·

Published

2012-07-20

·

Updated

2017-12-22

Description by

CVSS 2.0
8.5
High
MetricsAV:N/AC:M/Au:S/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions OSIsoft PI OPC DA Interface versions prior to 2.3.20.9
Description The issue is related to a stack-based buffer overflow that allows remote authenticated users to execute arbitrary code. This is achieved by sending packet data during the processing of messages associated with OPC items.
Recommendations For versions prior to 2.3.20.9, update to version 2.3.20.9 or later to resolve the issue.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾