PT-2012-4769

CVE-2012-3505

·

Published

2012-10-09

·

Updated

2024-06-15

Description by

CVSS 2.0
5.0
Medium
MetricsAV:N/AC:L/Au:N/C:N/I:N/A:P
Name of the Vulnerable Software and Affected Versions Tinyproxy versions 1.8.3 and earlier
Description The issue allows remote attackers to cause a denial of service, consuming CPU and memory, via two methods: (1) sending a large number of headers or (2) sending a large number of forged headers that trigger hash collisions predictably.
Recommendations For Tinyproxy versions 1.8.3 and earlier, consider updating to a version later than 1.8.3 to resolve the issue. As a temporary workaround, consider restricting the number of headers allowed in incoming requests to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Weakness enumeration
Related identifiers
DSA-2564-1
OPENSUSE-SU-2024:0119-1
OPENSUSE-SU-2024:10460-1
Found an issue in the description? Have something to add? Feel free to write us 👾