PT-2012-5299

CVE-2012-4271

·

Published

2012-08-13

·

Updated

2017-08-29

Description by

CVSS 2.0
4.3
Medium
MetricsAV:N/AC:M/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions Bad Behavior plugin versions prior to 2.0.47 Bad Behavior plugin versions 2.2.x prior to 2.2.5
Description The issue allows remote attackers to inject arbitrary web script or HTML via certain parameters, including PATH INFO, httpbl key, httpbl maxage, httpbl threat, reverse proxy addresses, or reverse proxy header.
Recommendations For Bad Behavior plugin versions prior to 2.0.47, update to version 2.0.47 or later. For Bad Behavior plugin versions 2.2.x prior to 2.2.5, update to version 2.2.5 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾