PT-2012-5301
CVE-2012-4273
·
Published
2012-08-13
·
Updated
2017-08-29
Description by
CVSS 2.0
4.3
MediumMetricsAV:N/AC:M/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions
2 Click Social Media Buttons plugin version prior to 0.34
Description
The issue is related to a cross-site scripting (XSS) vulnerability. It allows remote attackers to inject arbitrary web script or HTML via the
xing-url parameter in the libs/xing.php file.Recommendations
For versions prior to 0.34, update to version 0.34 or later to resolve the issue. As a temporary workaround, consider restricting access to the
xing-url parameter in the affected API endpoint until the issue is resolved. Found an issue in the description? Have something to add? Feel free to write us 👾