PT-2012-5385
CVE-2012-4414
·
Published
2012-11-29
·
Updated
2024-06-15
Description by
CVSS 2.0
6.5
MediumMetricsAV:N/AC:L/Au:S/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
Oracle MySQL versions prior to 5.5.29
MariaDB versions 5.1.x through 5.1.62
MariaDB versions 5.2.x through 5.2.12
MariaDB versions 5.3.x through 5.3.7
MariaDB versions 5.5.x through 5.5.25
Description
Multiple SQL injection vulnerabilities in the replication code allow remote authenticated users to execute arbitrary SQL commands via vectors related to the binary log.
Recommendations
For Oracle MySQL versions prior to 5.5.29, update to version 5.5.29 or later.
For MariaDB versions 5.1.x through 5.1.62, update to a version later than 5.1.62.
For MariaDB versions 5.2.x through 5.2.12, update to a version later than 5.2.12.
For MariaDB versions 5.3.x through 5.3.7, update to a version later than 5.3.7.
For MariaDB versions 5.5.x through 5.5.25, update to a version later than 5.5.25.
Found an issue in the description? Have something to add? Feel free to write us 👾