PT-2012-5625
CVE-2012-4873
·
Published
2012-09-06
·
Updated
2012-09-10
Description by
CVSS 2.0
4.3
MediumMetricsAV:N/AC:M/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions
GNUBoard versions prior to 4.34.21
Description
A cross-site scripting issue exists due to insufficient validation of user input in the filename parameter of the file download function. This allows remote attackers to inject arbitrary web script or HTML.
Recommendations
For versions prior to 4.34.21, update to version 4.34.21 or later to resolve the issue. As a temporary workaround, consider restricting access to the file download function to minimize the risk of exploitation. Avoid using the
filename parameter in the affected function until the issue is resolved. Found an issue in the description? Have something to add? Feel free to write us 👾