PT-2012-5695

CVE-2012-4968

·

Published

2012-09-17

·

Updated

2022-05-17

Description by

CVSS 2.0
4.3
Medium
MetricsAV:N/AC:M/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions SilverStripe versions 2.3.x through 2.3.12 SilverStripe versions 2.4.x through 2.4.6
Description The issue allows remote attackers to inject arbitrary web script or HTML via crafted strings to various methods in a template. The affected methods include AbsoluteLinks, BigSummary, ContextSummary, EscapeXML, FirstParagraph, FirstSentence, Initial, LimitCharacters, LimitSentences, LimitWordCount, LimitWordCountXML, Lower, LowerCase, NoHTML, Summary, Upper, UpperCase, or URL.
Recommendations For SilverStripe versions 2.3.x through 2.3.12, update to version 2.3.13 or later. For SilverStripe versions 2.4.x through 2.4.6, update to version 2.4.7 or later. As a temporary workaround, consider restricting the use of the vulnerable methods in templates until a patch is available.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-V358-RVXR-WFFX
Found an issue in the description? Have something to add? Feel free to write us 👾