PT-2012-6057
CVE-2012-5610
·
Published
2012-12-18
·
Updated
2012-12-18
Description by
CVSS 2.0
6.5
MediumMetricsAV:N/AC:L/Au:S/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
ownCloud versions prior to 4.0.9
ownCloud versions 4.5.x prior to 4.5.2
Description
The issue allows remote authenticated users to execute arbitrary PHP code by uploading a file with a specially crafted name due to an incomplete blacklist vulnerability in lib/filesystem.php.
Recommendations
For ownCloud versions prior to 4.0.9, update to version 4.0.9 or later.
For ownCloud versions 4.5.x prior to 4.5.2, update to version 4.5.2 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾