PT-2012-6058

CVE-2012-5611

·

Published

2012-11-29

·

Updated

2024-06-15

Description by

CVSS 2.0
6.5
Medium
MetricsAV:N/AC:L/Au:S/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions Oracle MySQL versions 5.1.53 through 5.1.66 Oracle MySQL versions 5.5.19 through 5.5.28 MariaDB versions 5.1.x through 5.1.66 MariaDB versions 5.2.x through 5.2.13 MariaDB versions 5.3.x through 5.3.11 MariaDB versions 5.5.2.x through 5.5.28a
Description The issue is a stack-based buffer overflow in the acl get function, allowing remote authenticated users to execute arbitrary code via a long argument to the GRANT FILE command.
Recommendations For Oracle MySQL versions 5.1.53 through 5.1.66, update to a version later than 5.1.66. For Oracle MySQL versions 5.5.19 through 5.5.28, update to a version later than 5.5.28. For MariaDB versions 5.1.x through 5.1.66, update to a version later than 5.1.66. For MariaDB versions 5.2.x through 5.2.13, update to a version later than 5.2.13. For MariaDB versions 5.3.x through 5.3.11, update to a version later than 5.3.11. For MariaDB versions 5.5.2.x through 5.5.28a, update to a version later than 5.5.28a.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
CESA-2012_1551
DSA-2581-1
OPENSUSE-SU-2013_0011-1
OPENSUSE-SU-2013_0013-1
OPENSUSE-SU-2013_0014-1
OPENSUSE-SU-2013_0135-1
OPENSUSE-SU-2013_0156-1
OPENSUSE-SU-2024:10153-1
RHSA-2012:1551
RHSA-2012_1551
RHSA-2013:0180
RHSA-2013_0180
SUSE-RU-2023:3956-1
SUSE-RU-2023:4991-1
SUSE-SU-2013_0262-1
Found an issue in the description? Have something to add? Feel free to write us 👾