PT-2013-1109
CVE-2013-3229
·
Published
2013-02-18
·
Updated
2017-11-29
Description by
CVSS 2.0
7.2
HighMetricsAV:L/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
Linux kernel versions prior to 3.9-rc7
Description
The issue concerns multiple vulnerabilities in the Linux operating system, specifically in the Debian GNU/Linux package, which can be exploited by a local attacker to compromise the confidentiality, integrity, and availability of protected information. A specific vulnerability in the
iucv sock recvmsg function in net/iucv/af iucv.c of the Linux kernel allows local users to obtain sensitive information from kernel stack memory via a crafted recvmsg or recvfrom system call.Recommendations
For Linux kernel versions prior to 3.9-rc7, update to version 3.9-rc7 or later to resolve the issue.
As a temporary workaround, consider restricting access to the
iucv sock recvmsg function in net/iucv/af iucv.c to minimize the risk of exploitation. Found an issue in the description? Have something to add? Feel free to write us 👾