PT-2013-1142

CVE-2013-6407

·

Published

2013-12-07

·

Updated

2022-05-17

Description by

CVSS 2.0
6.4
Medium
MetricsAV:N/AC:L/Au:N/C:P/I:N/A:P
Name of the Vulnerable Software and Affected Versions Apache Solr versions prior to 4.1
Description The issue concerns multiple vulnerabilities in the lucene-solr package that can lead to breaches of confidentiality and availability of protected information. These vulnerabilities can be exploited remotely. Specifically, the UpdateRequestHandler for XML in Apache Solr is affected by an XML External Entity (XXE) issue, allowing remote attackers to have an unspecified impact via XML data containing an external entity declaration in conjunction with an entity reference.
Recommendations For Apache Solr versions prior to 4.1, update to version 4.1 or later to resolve the issue. As a temporary workaround, consider restricting access to the UpdateRequestHandler for XML to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-998J-J6V9-5846
DSA-2963-1
Found an issue in the description? Have something to add? Feel free to write us 👾