PT-2013-1245
CVE-2013-2126
·
Published
2013-05-31
·
Updated
2024-06-15
Description by
CVSS 2.0
7.5
HighMetricsAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
LibRaw versions prior to 0.15.4
LibRaw versions prior to 0.15.2
Description
The issue concerns multiple vulnerabilities in the libraw package, which can be exploited remotely, potentially leading to breaches of confidentiality, integrity, and availability of protected information. Specifically, multiple double free vulnerabilities exist in the LibRaw::unpack function, allowing context-dependent attackers to cause a denial of service and possibly execute arbitrary code via malformed image files, such as full-color Foveon or sRAW image files.
Recommendations
For versions prior to 0.15.2, consider updating to version 0.15.2 or later to address the double free vulnerabilities in the LibRaw::unpack function.
For versions prior to 0.15.4, update to version 0.15.4 or later to mitigate the identified security issues.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾