PT-2013-1269
CVE-2013-7421
·
Published
2013-12-31
·
Updated
2020-05-19
Description by
CVSS 2.0
10
HighMetricsAV:N/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
linux-image versions 3.13.0 through 3.16.0
linux-image versions prior to 3.18.5
Description
The issue affects the Linux kernel and can lead to breaches of confidentiality, integrity, and availability of protected information. It can be exploited locally or remotely. The Crypto API in the Linux kernel allows local users to load arbitrary kernel modules via a bind system call for an AF ALG socket with a module name in the
salg name field.Recommendations
For linux-image versions 3.13.0 through 3.16.0, update to a version prior to 3.18.5 to resolve the issue.
For linux-image versions prior to 3.18.5, update to version 3.18.5 or later to resolve the issue.
As a temporary workaround, consider restricting access to the AF ALG socket to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾