PT-2013-1879

CVE-2012-6084

·

Published

2013-01-01

·

Updated

2013-02-02

Description by

CVSS 2.0
5.0
Medium
MetricsAV:N/AC:L/Au:N/C:N/I:N/A:P
Name of the Vulnerable Software and Affected Versions ircd-ratbox versions prior to 3.0.8 Charybdis versions prior to 3.4.2
Description The issue is related to improper support for capability negotiation during server handshakes, which can be exploited by remote attackers to cause a denial of service. This is achieved by sending a malformed request, resulting in a NULL pointer dereference and daemon crash.
Recommendations For ircd-ratbox versions prior to 3.0.8, update to version 3.0.8 or later to resolve the issue. For Charybdis versions prior to 3.4.2, update to version 3.4.2 or later to resolve the issue.
Exploitability
Fix
Researchers
Vendors
Affected products
Related identifiers
DSA-2612-1
Found an issue in the description? Have something to add? Feel free to write us 👾