PT-2013-1890

CVE-2012-6100

·

Published

2013-01-27

·

Updated

2020-12-01

Description by

CVSS 2.0
4.0
Medium
MetricsAV:N/AC:L/Au:S/C:P/I:N/A:N
Name of the Vulnerable Software and Affected Versions Moodle versions 2.2.x through 2.2.6 Moodle versions 2.3.x through 2.3.3 Moodle versions 2.4.x through 2.4.0
Description The issue concerns the improper enforcement of the moodle/user:viewhiddendetails capability requirement in the report/outline/index.php file. This allows remote authenticated users to discover a hidden lastaccess value by reading an activity report.
Recommendations For Moodle versions 2.2.x through 2.2.6, update to version 2.2.7 or later. For Moodle versions 2.3.x through 2.3.3, update to version 2.3.4 or later. For Moodle versions 2.4.x through 2.4.0, update to version 2.4.1 or later.
Exploitability
Fix
Researchers
Vendors
Affected products
Weakness enumeration
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾