PT-2013-3289

CVE-2013-1633

·

Published

2013-08-06

·

Updated

2022-05-17

Description by

CVSS 3.1
8.3
High
MetricsAV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions setuptools versions prior to 0.7
Description The issue allows man-in-the-middle attackers to execute arbitrary code via a crafted response. This is due to the use of HTTP to retrieve packages from the PyPI repository and the lack of integrity checks on package contents.
Recommendations For versions prior to 0.7, update to version 0.7 or later to resolve the issue. As a temporary workaround, consider using a secure connection to retrieve packages, such as HTTPS, to minimize the risk of exploitation. Restrict access to the easy install function until a patch is available.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-27X4-J476-JP5F
AZL-41159
MGASA-2013-0274
PYSEC-2013-22
SUSE-SU-2014_0523-1
Found an issue in the description? Have something to add? Feel free to write us 👾