PT-2013-3369
CVE-2013-1738
·
Published
2013-09-17
·
Updated
2024-12-12
Description by
CVSS 2.0
9.3
HighMetricsAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
Mozilla Firefox versions prior to 24.0
Thunderbird versions prior to 24.0
SeaMonkey versions prior to 2.21
Description
The issue is related to a use-after-free vulnerability in the JS GetGlobalForScopeChain function. This vulnerability allows remote attackers to execute arbitrary code by leveraging incorrect garbage collection in situations involving default compartments and frame-chain restoration.
Recommendations
For Mozilla Firefox versions prior to 24.0, update to version 24.0 or later.
For Thunderbird versions prior to 24.0, update to version 24.0 or later.
For SeaMonkey versions prior to 2.21, update to version 2.21 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾