PT-2013-3567
CVE-2013-2156
·
Published
2013-07-01
·
Updated
2021-09-17
Description by
CVSS 2.0
7.5
HighMetricsAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
Apache Santuario XML Security for C++ versions prior to 1.7.1
Description
The issue is related to a heap-based buffer overflow in the Exclusive Canonicalization functionality. This can be exploited by remote attackers using a crafted PrefixList attribute, potentially leading to a denial of service or arbitrary code execution.
Recommendations
For versions prior to 1.7.1, update to version 1.7.1 or later to resolve the issue. As a temporary workaround, consider restricting access to the Exclusive Canonicalization functionality until a patch is applied.
Found an issue in the description? Have something to add? Feel free to write us 👾