PT-2013-3617
CVE-2013-2242
·
Published
2013-07-21
·
Updated
2020-12-01
Description by
CVSS 2.0
4.0
MediumMetricsAV:N/AC:L/Au:S/C:P/I:N/A:N
Name of the Vulnerable Software and Affected Versions
Moodle versions 2.1.10 and earlier, 2.2.x before 2.2.11, 2.3.x before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.1
Description
The issue allows remote authenticated users to bypass intended access restrictions via an HTTP session to a chat server, due to the mod/chat/gui sockets/index.php file not considering the mod/chat:chat capability before authorizing daemon-mode chat.
Recommendations
For versions 2.1.10 and earlier, update to a version later than 2.1.10.
For versions 2.2.x before 2.2.11, update to version 2.2.11 or later.
For versions 2.3.x before 2.3.8, update to version 2.3.8 or later.
For versions 2.4.x before 2.4.5, update to version 2.4.5 or later.
For versions 2.5.x before 2.5.1, update to version 2.5.1 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾