PT-2013-5041
CVE-2013-4491
·
Published
2013-12-07
·
Updated
2019-08-08
Description by
CVSS 2.0
4.3
MediumMetricsAV:N/AC:M/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions
Ruby on Rails versions 3.x through 3.2.15
Ruby on Rails versions 4.x through 4.0.1
Description
A cross-site scripting (XSS) issue exists in the internationalization component, allowing remote attackers to inject arbitrary web script or HTML via a crafted string. This string triggers the generation of a fallback string by the i18n gem, which is used in the
actionpack/lib/action view/helpers/translation helper.rb file.Recommendations
For Ruby on Rails versions 3.x through 3.2.15, update to version 3.2.16 or later.
For Ruby on Rails versions 4.x through 4.0.1, update to version 4.0.2 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾