PT-2013-5884

CVE-2013-5960

·

Published

2013-09-30

·

Updated

2022-05-14

Description by

CVSS 2.0
5.8
Medium
MetricsAV:N/AC:M/Au:N/C:P/I:P/A:N
Name of the Vulnerable Software and Affected Versions OWASP Enterprise Security API (ESAPI) for Java versions prior to 2.1.0.1
Description The authenticated-encryption feature in the symmetric-encryption implementation does not properly resist tampering with serialized ciphertext. This makes it easier for remote attackers to bypass intended cryptographic protection mechanisms via an attack against the intended cipher mode in a non-default configuration.
Recommendations For versions prior to 2.1.0.1, update to version 2.1.0.1 or later to resolve the issue.
Exploitability
Exploit
Fix
Researchers
Vendors
Affected products
Related identifiers
GHSA-2G56-7JV7-WXXQ
Found an issue in the description? Have something to add? Feel free to write us 👾