PT-2013-6024

CVE-2013-6386

·

Published

2013-11-30

·

Updated

2014-01-14

Description by

CVSS 2.0
6.8
Medium
MetricsAV:N/AC:M/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions Drupal versions 6.x through 6.28 Drupal versions 7.x through 7.23
Description The issue allows remote attackers to predict security strings and bypass intended restrictions via a brute force attack, due to the use of the PHP mt rand function to generate random numbers with predictable seeds.
Recommendations For Drupal versions 6.x through 6.28, update to version 6.29 or later. For Drupal versions 7.x through 7.23, update to version 7.24 or later.
Exploitability
Fix
Researchers
Vendors
Affected products
Weakness enumeration
Related identifiers
DSA-2804-1
DSA-2828-1
MGASA-2013-0359
Found an issue in the description? Have something to add? Feel free to write us 👾