PT-2013-6039

CVE-2013-6416

·

Published

2013-12-07

·

Updated

2019-08-08

Description by

CVSS 2.0
4.3
Medium
MetricsAV:N/AC:M/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions Ruby on Rails versions 4.0.0 through 4.0.1
Description A cross-site scripting (XSS) issue exists in the simple format helper, located in actionpack/lib/action view/helpers/text helper.rb, allowing remote attackers to inject arbitrary web script or HTML via a crafted HTML attribute. This enables attackers to execute malicious scripts on the client-side.
Recommendations For Ruby on Rails versions 4.0.0 through 4.0.1, update to version 4.0.2 or later to resolve the issue. As a temporary workaround, consider restricting the use of the simple format helper until a patch is applied.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-W37C-Q653-QG95
Found an issue in the description? Have something to add? Feel free to write us 👾