PT-2014-1473

CVE-2014-1556

·

Published

2014-07-22

·

Updated

2024-12-12

Description by

CVSS 2.0
9.3
High
MetricsAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions Mozilla Firefox versions prior to 31.0 Firefox ESR versions prior to 24.7 Thunderbird versions prior to 24.7
Description The issue allows remote attackers to execute arbitrary code via crafted WebGL content constructed with the Cesium JavaScript library. This can be achieved by specially forming the content of WebGL using the Cesium JavaScript library, enabling remote execution of arbitrary code.
Recommendations For Mozilla Firefox versions prior to 31.0, update to version 31.0 or later. For Firefox ESR versions prior to 24.7, update to version 24.7 or later. For Thunderbird versions prior to 24.7, update to version 24.7 or later.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
ALT-PU-2014-1978
ALT-PU-2014-1979
CESA-2014_0918
CESA-2014_0919
DSA-2986-1
DSA-2996-1
MGASA-2014-0293
MGASA-2014-0419
OPENSUSE-SU-2014_0939-1
OPENSUSE-SU-2014_0950-1
OPENSUSE-SU-2014_0976-1
OPENSUSE-SU-2014_1100-1
OPENSUSE-SU-2024:10071-1
OPENSUSE-SU-2024:10230-1
OPENSUSE-SU-2024:14572-1
RHSA-2014:0918
RHSA-2014_0918
RHSA-2014:0919
RHSA-2014_0919
USN-2295-1
USN-2296-1
Found an issue in the description? Have something to add? Feel free to write us 👾