PT-2014-1707
CVE-2014-3609
·
Published
2014-03-16
·
Updated
2017-01-07
Description by
CVSS 2.0
5.0
MediumMetricsAV:N/AC:L/Au:N/C:N/I:N/A:P
Name of the Vulnerable Software and Affected Versions
Squid versions 3.x prior to 3.3.12
Squid versions 3.4.x prior to 3.4.6
Description
The issue allows remote attackers to cause a denial of service, potentially leading to disruption of protected information availability. This can be achieved through a request containing specially crafted
Range headers with unidentifiable byte-range values, affecting the HttpHdrRange.cc component in Squid.Recommendations
For Squid versions 3.x prior to 3.3.12, update to version 3.3.12 or later.
For Squid versions 3.4.x prior to 3.4.6, update to version 3.4.6 or later.
As a temporary workaround, consider restricting access to the
HttpHdrRange.cc component to minimize the risk of exploitation.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾