PT-2014-1757

CVE-2014-5165

·

Published

2014-08-01

·

Updated

2024-06-15

Description by

CVSS 2.0
5.0
Medium
MetricsAV:N/AC:L/Au:N/C:N/I:N/A:P
Name of the Vulnerable Software and Affected Versions Wireshark versions 1.10.x through 1.10.8
Description The issue exists in the dissect ber constrained bitstring function due to incorrect validation of padding values in the ASN.1 BER dissector. This allows remote attackers to cause a denial of service, resulting in a buffer underflow and application crash, by sending a specially crafted packet.
Recommendations For Wireshark versions 1.10.x through 1.10.8, update to version 1.10.9 or later to resolve the issue. As a temporary workaround, consider restricting access to the dissect ber constrained bitstring function in the ASN.1 BER dissector to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
ALT-PU-2014-2080
DSA-3002-1
MGASA-2014-0326
OPENSUSE-SU-2024:10199-1
Found an issue in the description? Have something to add? Feel free to write us 👾