PT-2014-1942
CVE-2014-9644
·
Published
2014-12-31
·
Updated
2020-05-21
Description by
CVSS 2.0
10
HighMetricsAV:N/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
linux-image versions 3.13.0 through 3.16.0
linux-image versions prior to 3.18.5
Description
The issue affects the Linux kernel, allowing local users to load arbitrary kernel modules via a bind system call for an AF ALG socket with a parenthesized module template expression in the
salg name field. This can lead to a breach of confidentiality, integrity, and availability of protected information. The exploitation can be carried out locally.Recommendations
For linux-image versions 3.13.0 through 3.16.0, update to a version prior to 3.18.5 to resolve the issue.
For linux-image versions prior to 3.18.5, update to version 3.18.5 or later to resolve the issue.
As a temporary workaround, consider restricting access to the AF ALG socket to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾