PT-2014-1974
CVE-2014-9637
·
Published
2014-12-31
·
Updated
2018-05-07
Description by
CVSS 2.0
7.1
HighMetricsAV:N/AC:M/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
GNU patch versions 2.7.2 and earlier
Description
The issue is related to errors in resource management, specifically memory consumption, which can lead to a denial of service. This can be triggered by a remote attacker using a crafted diff file, resulting in a segmentation fault. The estimated number of potentially affected devices is not specified.
Recommendations
For GNU patch versions 2.7.2 and earlier, update to a version later than 2.7.2 to resolve the issue. As a temporary workaround, consider restricting the use of crafted diff files to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾