PT-2014-2073

CVE-2010-1441

·

Published

2014-12-26

·

Updated

2014-12-29

Description by

CVSS 2.0
7.5
High
MetricsAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions VideoLAN VLC media player versions prior to 1.0.6
Description The issue allows remote attackers to cause a denial of service or possibly execute arbitrary code via a crafted byte stream to the A/52, DTS, or MPEG Audio decoder. This is due to multiple heap-based buffer overflows in the affected software.
Recommendations For versions prior to 1.0.6, update to version 1.0.6 or later to resolve the issue. As a temporary workaround, consider restricting access to the A/52, DTS, and MPEG Audio decoders until a patch is applied. Avoid using these decoders with untrusted input sources to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾