PT-2014-2287

CVE-2012-4915

·

Published

2013-01-08

·

Updated

2017-08-29

Description by

CVSS 2.0
5.0
Medium
MetricsAV:N/AC:L/Au:N/C:P/I:N/A:N
Name of the Vulnerable Software and Affected Versions Google Doc Embedder plugin versions prior to 2.5.4
Description The issue allows remote attackers to read arbitrary files. This is achieved by using a .. (dot dot) in the file parameter to the "libs/pdf.php" endpoint.
Recommendations For versions prior to 2.5.4, update to version 2.5.4 or later to resolve the issue. As a temporary workaround, consider restricting access to the "libs/pdf.php" endpoint to minimize the risk of exploitation. Avoid using the file parameter in the affected endpoint until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾