PT-2014-2359
CVE-2012-5700
·
Published
2014-09-22
·
Updated
2017-08-29
Description by
CVSS 2.0
4.3
MediumMetricsAV:N/AC:M/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions
Baby Gekko versions prior to 1.2.2f
Description
The issue allows remote attackers to inject arbitrary web script or HTML. This can be achieved via the
id parameter to "admin/index.php", or the username or password parameters in "blocks/loginbox/loginbox.template.php" to "index.php".Recommendations
For versions prior to 1.2.2f, update to version 1.2.2f or later to resolve the issue. As a temporary workaround, consider restricting access to the affected API endpoints, such as "admin/index.php" and "index.php", to minimize the risk of exploitation. Avoid using the
id, username, and password parameters in the affected endpoints until the issue is resolved. Found an issue in the description? Have something to add? Feel free to write us 👾