PT-2014-2488
CVE-2013-1756
·
Published
2014-06-09
·
Updated
2018-08-13
Description by
CVSS 2.0
7.5
HighMetricsAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
Dragonfly gem versions 0.7 through 0.8.5
Dragonfly gem versions 0.9.x through 0.9.12
Description
The issue allows remote attackers to execute arbitrary code via a crafted request when the Dragonfly gem is used with Ruby on Rails.
Recommendations
For Dragonfly gem versions 0.7 through 0.8.5, update to version 0.8.6 or later.
For Dragonfly gem versions 0.9.x through 0.9.12, update to version 0.9.13 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾