PT-2014-2791
CVE-2013-4431
·
Published
2014-05-19
·
Updated
2014-05-19
Description by
CVSS 2.0
5.5
MediumMetricsAV:N/AC:L/Au:S/C:N/I:P/A:P
Name of the Vulnerable Software and Affected Versions
Mahara versions prior to 1.5.12
Mahara versions 1.6.x prior to 1.6.7
Mahara versions 1.7.x prior to 1.7.3
Description
The issue allows remote authenticated users to modify arbitrary blocks via the block id in an edit request, due to improper access prevention to blocks.
Recommendations
For Mahara versions prior to 1.5.12, update to version 1.5.12 or later.
For Mahara versions 1.6.x prior to 1.6.7, update to version 1.6.7 or later.
For Mahara versions 1.7.x prior to 1.7.3, update to version 1.7.3 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾