PT-2014-3450
CVE-2014-0046
·
Published
2014-02-27
·
Updated
2018-08-28
Description by
CVSS 2.0
2.6
LowMetricsAV:N/AC:H/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions
Ember.js versions 1.2.x through 1.2.1
Ember.js versions 1.3.x through 1.3.1
Ember.js versions 1.4.x through 1.4.0-beta.5
Description
A cross-site scripting (XSS) issue exists in the link-to helper of Ember.js. This allows remote attackers to inject arbitrary web script or HTML via the title attribute when the helper is used in non-block form.
Recommendations
For Ember.js versions 1.2.x through 1.2.1, update to version 1.2.2 or later.
For Ember.js versions 1.3.x through 1.3.1, update to version 1.3.2 or later.
For Ember.js versions 1.4.x through 1.4.0-beta.5, update to version 1.4.0-beta.6 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾