PT-2014-3468

CVE-2014-0080

·

Published

2014-02-20

·

Updated

2019-08-08

Description by

CVSS 2.0
6.8
Medium
MetricsAV:N/AC:M/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions Ruby on Rails versions 4.0.x through 4.0.2 Ruby on Rails version 4.1.0.beta1
Description The issue allows remote attackers to execute SQL commands via vectors involving backslash characters that are not properly handled in operations on array columns when PostgreSQL is used. This is due to a SQL injection vulnerability in the activerecord/lib/active record/connection adapters/postgresql/cast.rb file in Active Record.
Recommendations For Ruby on Rails versions 4.0.x through 4.0.2, update to version 4.0.3 or later. For Ruby on Rails version 4.1.0.beta1, consider upgrading to a later version that addresses this issue. As a temporary workaround, consider restricting the use of backslash characters in operations on array columns until a patch is available.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-HQF9-RC9J-5FMJ
MGASA-2014-0191
Found an issue in the description? Have something to add? Feel free to write us 👾