PT-2014-3830
CVE-2014-0768
·
Published
2014-04-12
·
Updated
2025-09-19
Description by
CVSS 2.0
7.5
HighMetricsAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
Advantech WebAccess versions prior to 7.2
Description
The issue is related to a stack-based buffer overflow that allows remote attackers to execute arbitrary code. This is achieved by providing a long
AccessCode2 argument.Recommendations
For versions prior to 7.2, update to version 7.2 or later to resolve the issue. As a temporary workaround, consider restricting access to the
webvact.ocx module to minimize the risk of exploitation. Avoid using long AccessCode2 arguments in the affected API endpoint until the issue is resolved. Found an issue in the description? Have something to add? Feel free to write us 👾