PT-2014-3947

CVE-2014-0921

·

Published

2014-04-15

·

Updated

2017-08-29

Description by

CVSS 2.0
4.3
Medium
MetricsAV:N/AC:M/Au:N/C:N/I:N/A:P
Name of the Vulnerable Software and Affected Versions IBM MessageSight versions 1.x before 1.1.0.0-IBM-IMA-IT01015
Description The issue allows remote attackers to cause a denial of service, resulting in a daemon crash and message data loss, via malformed headers during a WebSockets connection upgrade.
Recommendations For IBM MessageSight versions 1.x before 1.1.0.0-IBM-IMA-IT01015, update to version 1.1.0.0-IBM-IMA-IT01015 or later to resolve the issue. As a temporary workaround, consider restricting WebSockets connection upgrades to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾