PT-2014-4235
CVE-2014-1583
·
Published
2014-10-01
·
Updated
2024-12-12
Description by
CVSS 2.0
5.0
MediumMetricsAV:N/AC:L/Au:N/C:P/I:N/A:N
Name of the Vulnerable Software and Affected Versions
Mozilla Firefox versions prior to 33.0
Mozilla Firefox ESR versions prior to 31.2
Description
The issue is related to the Alarm API in Mozilla Firefox, which does not properly restrict toJSON calls. This allows remote attackers to bypass the Same Origin Policy via crafted API calls, accessing sensitive information within the JSON data of an alarm.
Recommendations
For Mozilla Firefox versions prior to 33.0, update to version 33.0 or later.
For Mozilla Firefox ESR versions prior to 31.2, update to version 31.2 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾