PT-2014-4318

CVE-2014-1829

·

Published

2014-09-19

·

Updated

2026-10-04

Description by

CVSS 4.0
6.9
Medium
MetricsAV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
Name of the Vulnerable Software and Affected Versions Requests (aka python-requests) versions prior to 2.3.0
Description The issue allows remote servers to obtain a netrc password by reading the Authorization header in a redirected request.
Recommendations For versions prior to 2.3.0, update to version 2.3.0 or later to resolve the issue.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-CFJ3-7X9C-4P3H
DSA-3146-1
ECHO-3146-7A27-2D5A
MGASA-2014-0409
OPENSUSE-SU-2024:10125-1
OPENSUSE-SU-2024:10482-1
OPENSUSE-SU-2024:11266-1
OPENSUSE-SU-2024:13999-1
OPENSUSE-SU-2026:12038-1
PYSEC-2014-13
SUSE-FU-2022:0444-1
SUSE-FU-2022:0445-1
USN-2382-1
Found an issue in the description? Have something to add? Feel free to write us 👾