PT-2014-4354
CVE-2014-1904
·
Published
2014-03-20
·
Updated
2022-05-14
Description by
CVSS 2.0
4.3
MediumMetricsAV:N/AC:M/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions
Spring Framework versions 3.0.0 through 3.2.7
Spring Framework versions 4.0.0 through 4.0.1
Description
A cross-site scripting (XSS) issue allows remote attackers to inject arbitrary web script or HTML via the requested URI in a default action. This occurs in the web/servlet/tags/form/FormTag.java component of Spring MVC.
Recommendations
For Spring Framework versions 3.0.0 through 3.2.7, update to version 3.2.8 or later.
For Spring Framework versions 4.0.0 through 4.0.1, update to version 4.0.2 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾