PT-2014-4770
CVE-2014-2538
·
Published
2014-03-25
·
Updated
2017-10-24
Description by
CVSS 4.0
5.3
MediumMetricsAV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
Name of the Vulnerable Software and Affected Versions
rack-ssl gem versions prior to 1.4.0
Description
The issue allows remote attackers to inject arbitrary web script or HTML via a URI. This might not be properly handled by third-party adapters such as JRuby-Rack.
Recommendations
For versions prior to 1.4.0, update to version 1.4.0 or later to resolve the issue. As a temporary workaround, consider restricting access to the
lib/rack/ssl.rb file until a patch is available. Avoid using URIs that might be improperly handled by third-party adapters. Found an issue in the description? Have something to add? Feel free to write us 👾