PT-2014-4893

CVE-2014-2736

·

Published

2014-04-24

·

Updated

2019-10-22

Description by

CVSS 2.0
7.5
High
MetricsAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions MODX Revolution versions prior to 2.2.14
Description The issue allows remote attackers to execute arbitrary SQL commands. This can be achieved via the session ID (PHPSESSID) to index.php. Additionally, remote authenticated users can execute arbitrary SQL commands via the user parameter to connectors/security/message.php or the id parameter to manager/index.php.
Recommendations For MODX Revolution versions prior to 2.2.14, update to version 2.2.14 or later to resolve the issue. As a temporary workaround, consider restricting access to the connectors/security/message.php and manager/index.php endpoints until a patch is available. Avoid using the user and id parameters in the affected API endpoints until the issue is resolved.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾