PT-2014-5350
CVE-2014-3482
·
Published
2014-07-07
·
Updated
2019-08-08
Description by
CVSS 2.0
7.5
HighMetricsAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
Ruby on Rails versions prior to 3.2.19
Description
The issue is related to a SQL injection vulnerability in the PostgreSQL adapter for Active Record. This vulnerability allows remote attackers to execute arbitrary SQL commands by leveraging improper bitstring quoting.
Recommendations
For versions prior to 3.2.19, update to version 3.2.19 or later to resolve the issue.
Found an issue in the description? Have something to add? Feel free to write us 👾