PT-2014-5351
CVE-2014-3483
·
Published
2014-07-07
·
Updated
2019-08-08
Description by
CVSS 2.0
7.5
HighMetricsAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
Ruby on Rails versions 4.0.0 through 4.0.6
Ruby on Rails versions 4.1.0 through 4.1.2
Description
The issue is related to a SQL injection vulnerability in the PostgreSQL adapter for Active Record. This vulnerability allows remote attackers to execute arbitrary SQL commands by leveraging improper range quoting.
Recommendations
For Ruby on Rails versions 4.0.0 through 4.0.6, update to version 4.0.7 or later.
For Ruby on Rails versions 4.1.0 through 4.1.2, update to version 4.1.3 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾