PT-2014-5381

CVE-2014-3543

·

Published

2014-07-29

·

Updated

2022-05-13

Description by

CVSS 2.0
4.3
Medium
MetricsAV:N/AC:M/Au:N/C:P/I:N/A:N
Name of the Vulnerable Software and Affected Versions Moodle versions prior to 2.3.11 Moodle versions 2.4.x before 2.4.11 Moodle versions 2.5.x before 2.5.7 Moodle versions 2.6.x before 2.6.4 Moodle versions 2.7.x before 2.7.1
Description The issue allows remote attackers to read arbitrary files via a package with a manifest file containing an XML external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue affecting IMSCP resources and the IMSCC format.
Recommendations For versions prior to 2.3.11, update to version 2.3.11 or later. For versions 2.4.x before 2.4.11, update to version 2.4.11 or later. For versions 2.5.x before 2.5.7, update to version 2.5.7 or later. For versions 2.6.x before 2.6.4, update to version 2.6.4 or later. For versions 2.7.x before 2.7.1, update to version 2.7.1 or later.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-27J2-C838-C3QG
MGASA-2014-0308
Found an issue in the description? Have something to add? Feel free to write us 👾