PT-2014-5384
CVE-2014-3546
·
Published
2014-07-29
·
Updated
2022-05-13
Description by
CVSS 2.0
5.0
MediumMetricsAV:N/AC:L/Au:N/C:P/I:N/A:N
Name of the Vulnerable Software and Affected Versions
Moodle versions prior to 2.3.11
Moodle versions 2.4.x before 2.4.11
Moodle versions 2.5.x before 2.5.7
Moodle versions 2.6.x before 2.6.4
Moodle versions 2.7.x before 2.7.1
Description
The issue arises from the failure to enforce certain capability requirements in specific PHP files, allowing remote attackers to obtain potentially sensitive information, such as usernames and course details, by modifying URLs.
Recommendations
For versions prior to 2.3.11, update to version 2.3.11 or later.
For versions 2.4.x before 2.4.11, update to version 2.4.11 or later.
For versions 2.5.x before 2.5.7, update to version 2.5.7 or later.
For versions 2.6.x before 2.6.4, update to version 2.6.4 or later.
For versions 2.7.x before 2.7.1, update to version 2.7.1 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾