PT-2014-5693

CVE-2014-4045

·

Published

2014-06-17

·

Updated

2018-10-09

Description by

CVSS 2.0
4.3
Medium
MetricsAV:N/AC:M/Au:N/C:N/I:N/A:P
Name of the Vulnerable Software and Affected Versions Asterisk Open Source versions 12.x through 12.3.0
Description The issue allows remote attackers to cause a denial of service, resulting in an assertion failure and crash, via an unsubscribe request when not subscribed to the device. This occurs when the sub min expiry is set to zero in the Publish/Subscribe Framework in the PJSIP channel driver.
Recommendations For Asterisk Open Source versions 12.x through 12.3.0, update to version 12.3.1 or later to resolve the issue.
Exploitability
Fix
Impacts
Vendors
Affected products
Weakness enumeration
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾