PT-2014-6022
CVE-2014-4614
·
Published
2014-07-02
·
Updated
2014-07-09
Description by
CVSS 2.0
6.8
MediumMetricsAV:N/AC:M/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
Piwigo versions prior to 2.6.2
Description
The issue concerns multiple cross-site request forgery (CSRF) vulnerabilities. These vulnerabilities allow remote attackers to hijack the authentication of administrators for specific requests. The affected requests include methods such as
pwg.groups.addUser, pwg.groups.deleteUser, pwg.groups.setInfo, pwg.users.setInfo, pwg.permissions.add, and pwg.permissions.remove.Recommendations
For versions prior to 2.6.2, update to version 2.6.2 or later to resolve the issue. As a temporary workaround, consider restricting access to the affected methods until a patch is applied. Avoid using these methods in the affected API endpoints until the issue is resolved.
Found an issue in the description? Have something to add? Feel free to write us 👾