PT-2014-6077

CVE-2014-4725

·

Published

2014-07-27

·

Updated

2014-07-28

Description by

CVSS 2.0
7.5
High
MetricsAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions MailPoet Newsletters (wysija-newsletters) plugin versions prior to 2.6.7
Description The issue allows remote attackers to bypass authentication and execute arbitrary PHP code. This is achieved by uploading a crafted theme using the "wp-admin/admin-post.php" endpoint and then accessing the theme in "wp-content/uploads/wysija/themes/mailp/".
Recommendations For versions prior to 2.6.7, update to version 2.6.7 or later to resolve the issue. As a temporary workaround, consider restricting access to the "wp-admin/admin-post.php" endpoint and the "wp-content/uploads/wysija/themes/mailp/" directory to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾