PT-2014-8305

CVE-2014-7838

·

Published

2014-11-22

·

Updated

2022-05-13

Description by

CVSS 2.0
6.8
Medium
MetricsAV:N/AC:M/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions Moodle versions 2.4.11 and earlier Moodle versions 2.5.x before 2.5.9 Moodle versions 2.6.x before 2.6.6 Moodle versions 2.7.x before 2.7.3
Description The issue allows remote attackers to hijack the authentication of arbitrary users for requests that set a tracking preference within certain files, including mod/forum/deprecatedlib.php, mod/forum/forum.js, mod/forum/index.php, or mod/forum/lib.php. This is due to multiple cross-site request forgery (CSRF) vulnerabilities in the Forum module.
Recommendations For Moodle versions 2.4.11 and earlier, update to a version later than 2.4.11. For Moodle versions 2.5.x before 2.5.9, update to version 2.5.9 or later. For Moodle versions 2.6.x before 2.6.6, update to version 2.6.6 or later. For Moodle versions 2.7.x before 2.7.3, update to version 2.7.3 or later.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-43R4-VM25-QM78
MGASA-2014-0483
Found an issue in the description? Have something to add? Feel free to write us 👾